Browse Source

Use pylint 1.7.5 with fix for bad python3 import

Closes: https://pagure.io/freeipa/issue/7315
Signed-off-by: Christian Heimes <cheimes@redhat.com>
Reviewed-By: Petr Cech <pcech@redhat.com>
master
Christian Heimes 3 years ago
parent
commit
b567f3afea
3 changed files with 4 additions and 4 deletions
  1. +2
    -2
      .wheelconstraints.in
  2. +1
    -1
      ipapython/certdb.py
  3. +1
    -1
      ipaserver/install/installutils.py

+ 2
- 2
.wheelconstraints.in View File

@@ -9,5 +9,5 @@ ipapython == @VERSION@
ipaserver == @VERSION@
ipatests == @VERSION@

# we include some checks available only in pylint-1.7 and on
pylint >= 1.7
# upstream pylint 1.7.5 fixed bad python3 import of stat module
pylint >= 1.7.5

+ 1
- 1
ipapython/certdb.py View File

@@ -25,7 +25,7 @@ import io
import pwd
import grp
import re
import stat # pylint: disable=bad-python3-import
import stat
import tempfile
from tempfile import NamedTemporaryFile
import shutil


+ 1
- 1
ipaserver/install/installutils.py View File

@@ -33,7 +33,7 @@ import fileinput
import sys
import tempfile
import shutil
import stat # pylint: disable=bad-python3-import
import stat
import traceback
import textwrap
from contextlib import contextmanager


Loading…
Cancel
Save